易语言取出网页返回指定文本 | 站长之家查询网站get示例

主要讲述,如何取出get提交网页,返回文本,进行简单分类

.版本 2

.子程序 _按钮1_被单击

查询结果 = 编码_utf8到gb2312 (到文本 (网页_访问 (“https://apidatav2.chinaz.com/single/newicp?key=” + 编辑框1.内容 + “&domain=” + 编辑框2.内容, 0)))
文本_取出中间文本 (查询结果, “Code#引号:”, “,#引号Re”, , 真)
.判断开始 (文本_取出中间文本 (查询结果, “Code#引号:”, “,#引号Re”, , 真) = “1”)
    信息框 (“查询成功”, 0, “您好”)
.默认
    信息框 (“查询失败”, 0, “您好”)
.判断结束
编辑框3.内容 = 文本_取出中间文本 (查询结果, “Name#引号:#引号”, “#引号,#引号Com”, , 真)
编辑框4.内容 = 文本_取出中间文本 (查询结果, “Type#引号:#引号”, “#引号,#引号Site”, , 真)
编辑框5.内容 = 文本_取出中间文本 (查询结果, “Domain#引号:#引号”, “#引号,#引号Ow”, , 真)
编辑框6.内容 = 文本_取出中间文本 (查询结果, “SiteLicense#引号:#引号”, “#引号,#引号Site”, , 真)
编辑框7.内容 = 文本_取出中间文本 (查询结果, “SiteName#引号:#引号”, “#引号,#引号Main”, , 真)
编辑框8.内容 = 文本_取出中间文本 (查询结果, “Domain#引号:#引号”, “#引号,#引号Ow”, , 真)
编辑框9.内容 = 文本_取出中间文本 (查询结果, “VerifyTime#引号:#引号”, “#引号,#引号Do”, , 真)
编辑框10.内容 = 文本_取出中间文本 (查询结果, “Owner#引号:#引号”, “#引号,#引号Lim”, , 真)
编辑框11.内容 = 文本_取出中间文本 (查询结果, “LimitAccess#引号:#引号”, “#引号,#引号Ser”, , 真)
编辑框12.内容 = 文本_取出中间文本 (查询结果, “viceLicence#引号:#引号”, “#引号}}”, , 真)

返回中的文本内容带“”的使用#引号代替

用到初级命令

文本_取出中间文本(,,,,)

用到精易模板

部分文章/资源来源于网络,文章标题下部均已标注来源,如有侵权,请点击此处联系客服进行删除,本站将会在第一时间内进行处理! 

如果您要搬运本站文章,请在文章底部标注

图床支持:https://cos.bheo.cn/

如果文章帮助到您,还请您点击一下广告支持本站一下!

给TA鼓励
共{{data.count}}人
人已鼓励
0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索