易语言取出网页返回指定文本 | 站长之家查询网站get示例
首页>>易语言基础>>正文
易语言取出网页返回指定文本 | 站长之家查询网站get示例-华易资讯

主要讲述,如何取出get提交网页,返回文本,进行简单分类

.版本 2

.子程序 _按钮1_被单击

查询结果 = 编码_utf8到gb2312 (到文本 (网页_访问 (“https://apidatav2.chinaz.com/single/newicp?key=” + 编辑框1.内容 + “&domain=” + 编辑框2.内容, 0)))
文本_取出中间文本 (查询结果, “Code#引号:”, “,#引号Re”, , 真)
.判断开始 (文本_取出中间文本 (查询结果, “Code#引号:”, “,#引号Re”, , 真) = “1”)
    信息框 (“查询成功”, 0, “您好”)
.默认
    信息框 (“查询失败”, 0, “您好”)
.判断结束
编辑框3.内容 = 文本_取出中间文本 (查询结果, “Name#引号:#引号”, “#引号,#引号Com”, , 真)
编辑框4.内容 = 文本_取出中间文本 (查询结果, “Type#引号:#引号”, “#引号,#引号Site”, , 真)
编辑框5.内容 = 文本_取出中间文本 (查询结果, “Domain#引号:#引号”, “#引号,#引号Ow”, , 真)
编辑框6.内容 = 文本_取出中间文本 (查询结果, “SiteLicense#引号:#引号”, “#引号,#引号Site”, , 真)
编辑框7.内容 = 文本_取出中间文本 (查询结果, “SiteName#引号:#引号”, “#引号,#引号Main”, , 真)
编辑框8.内容 = 文本_取出中间文本 (查询结果, “Domain#引号:#引号”, “#引号,#引号Ow”, , 真)
编辑框9.内容 = 文本_取出中间文本 (查询结果, “VerifyTime#引号:#引号”, “#引号,#引号Do”, , 真)
编辑框10.内容 = 文本_取出中间文本 (查询结果, “Owner#引号:#引号”, “#引号,#引号Lim”, , 真)
编辑框11.内容 = 文本_取出中间文本 (查询结果, “LimitAccess#引号:#引号”, “#引号,#引号Ser”, , 真)
编辑框12.内容 = 文本_取出中间文本 (查询结果, “viceLicence#引号:#引号”, “#引号}}”, , 真)

返回中的文本内容带“”的使用#引号代替

用到初级命令

文本_取出中间文本(,,,,)

用到精易模板

给TA打赏
共{{data.count}}人
人已打赏
易语言基础

如何用易语言get提交网页api指定内容

2022-5-2 12:56:00

易语言基础

易语言如何网页填表登录网页

2022-5-10 10:28:34

0 条回复 A文章作者 M管理员
随机诗词:
    暂无讨论,说说你的看法吧
搜索
error: